Use the how-to tabs below for all your Plesk needs. For managed clients who have questions not answered in this space, feel free to chat with us!
How to Change the Version of ASP.net in Plesk
1) Sign in to Plesk
2) Search for the domain in the search box at the top right:
3) Click on “Websites and Domains” at the top
4) Click on “Advanced Operations”
5) Click on “Website Scripting and Security”
6) Change the version in the drop down for ASP .net support.
Fix HTTP Error 404.3 - Not Found at index.php
Error
HTTP Error 404.3 - Not Found
The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.
Cause
There is very likely no PHP handler in place for this site in IIS. Thus, there is nothing available to serve the file properly.
Solution
You will need to go into Plesk, search for the affected domain, and navigate to the domain's control panel. From here you can click the domain to manage its WebHosting Settings. On this page, you can manage things like ASP, CGI, Perl, and of course PHP. You should just be able to disable and re-enable PHP to re-add the handlers.
If you run into any errors about duplicate handlers, you will need to go to into IIS and navigate to the handler mappings for the affected domain. In this window, you will want to Revert to parent. After the handler mappings have been reset, you should now be able to go back into Plesk and disable/re-enable PHP to resolve the issue.
How to Change Default Webmail Client in Plesk
This article covers how to change the default webmail client in Plesk.
- Access your Plesk control panel.
(If you are accessing from a reseller or as admin you will want to navigate to Domains >> Select the domain you wish to change >> Manage Hosting)
- Click the "Mail" tab.
- Check the boxes next to the e-mail account(s) you wish to modify.
- Select "change settings"
- Select the webmail client you wish to use from the drop-down next to "webmail"
- Click "OK"
Make a backup of the Plesk Server 11 before attempting any upgrades! We also recommend rebooting your server before starting the upgrade to ensure everything is in proper order going into the procedure.
In Linux or Windows via Plesk Control Panel:
- Login to the Plesk Control Panel.
- Click on the "Server" tab at the top of the page.
- On the page, navigate to the "Panel" area. Under this area, click the option "Update and Upgrades" link.
- Within the new page, to upgrade a component (Nginx), click on the "Update Components" link.
- Select the component you want to upgrade (Nginx), and click continue.
- The upgrade has now begun, which could take up to 20 minutes depending on your bandwidth and server specifications. Upon completion, a "Successfully Completed" message will be displayed in green.
- Once fully upgraded, we can now enable the component (Nginx).
- Navigate to the "Tools and Settings" area.
- Click on "Updates and Upgrades"
- Click on "Add Components"
- Select Nginx and press Continue.
- Once Nginx has been successfully added, you will want to navigate to "Service Management" within "Tools and Settings", and run the Reverse Proxy Server (Nginx).
- You are done!
In Linux via SSH/Command Line:
- First install Nginx component using Plesk autoinstaller:
/usr/local/psa/admin/sbin/autoinstaller
- Next enable Reverse Proxy Server (Nginx) service via command line:
/usr/local/psa/admin/sbin/nginxmng -e
- Then disable nginx service use the command:
/usr/local/psa/admin/sbin/nginxmng -d
- Last, check the current nginx component status:
/usr/local/psa/admin/sbin/nginxmng -s
How to Retrieve Plesk Admin Password Via Remote Desktop
In the event your Plesk admin password is different from your admin remote desktop password, you can easily retrieve this password if forgotten. Here's how:
Connect to the server via Remote Desktop.
From the Start menu, select the Run... option and type in “cmd”.
This will open up the command prompt.
Enter in the following to retrieve the current Plesk admin password:
"%plesk_bin%\plesksrvclient" -get
Plesk’s PSA database holds all of the information the panel uses to manage the server. We can use this to our advantage when we want to automate a task for many items at once. Automation saves us time and ultimately money (you know, because time is money, right?).
Here is the code we will be looking at:
$sql = "select login, home from sys_users"
& "${env:plesk_bin}\dbclient.exe" --direct-sql --sql="$sql" | select-string -Not -Pattern "^$" | select -skip 1 | % {
$line = $_ -replace "\s+", " "
$parts = $line.split(' ')
$user = $parts[0];
$home = $parts[1];
echo "Home: $home, User: $user";
}
I will explain it in parts:
$sql = "select login, home from sys_users"
& "${env:plesk_bin}\dbclient.exe" --direct-sql --sql="$sql"
First, we have the actual dbclient command, the dbclient executable can be found in %plesk_bin%. In powershell, environment variables like this are accessed as “$env:plesk_bin”. We use the ${env:plesk_bin}
format to ensure there is conflict with how we are calling the variable. I have used an intermediate $sql variable to make it a little easier to read.
select-string -Not -Pattern "^$"
The dbclient output cannot be used right out of the gate, we need to format it first. To do this, we must first pipe the output into select-string -Not -Pattern "^$"
so we can strip out any empty lines. This code simply means “Ignore all lines that start and then end immediately” (ie, empty line).
select -skip 1
This line simply skips the first line of output which will be the column headers. We don’t want this information in our loop, so we can just skip it.
Now we take this formatted output and pipe it into a for loop (% { }). “%” is a shortcut command for “for-each”. It allows us to run commands against each line output.
$line = $_ -replace "\s+", " "
The first line in the loop ensures that there are no double spaces. It will shrink any number of sequential spaces down to a single space and saves it to $line. $_ is a reserved variable that contains each line in the for loop.
$parts = $line.split(' ')
This split command is where the magic happens. Here, we split the $line from the previous step in to $parts so we can access the data found in each individual column. $parts is an array of this data. $parts[0] is the first column, $parts[1] is the second, etc depending on how many columns you requested in the SELECT query.
$user = $parts[0];
$home = $parts[1];
Using the $parts variable, we assign more human readable variables per the previous paragraph. From here, we can now easily utilize the data from the dbclient output:
echo "Home: $home, User: $user";
The echo line at the end is just used as a proof of concept, but this process can be incredibly powerful.
Reset Plesk Admin Password Via Remote Desktop
In the event you need to change the admin password and do not have access into Plesk, this can be done by doing the following:
Connect to the server via Remote Desktop.
From the Start menu, select the Run... option and type in “cmd”.
This will open up the command prompt.
Enter in the following to retrieve the current Plesk admin password:
"%plesk_bin%\plesksrvclient" -set <new_password> true
- Replace <new_password> with the actual new admin password.
This procedure is only assured to work in Plesk 11
Login to the Plesk control panel as admin.
When logged in, look at the right hand side of the window for the area called "Server Management".
Expand this category and click on the menu for "Tools & Settings".
Once you have entered into Tools & Settings, look for an area called "Server Management".
Under this area, click on the link called "Services Management"
This area will show you all the current services within Plesk, and whether they are started or stopped. From this menu you can also Stop, Start, or Restart any service within Plesk. This is an extremely useful area for ensuring services are on (before troubleshooting them for issues) and to possibly restart any services that require rebooting.